How to install FBReader e-Book Reader in Ubuntu 18.04

In this article, we will learn How to install FBReader e-Book Reader in Ubuntu 18.04. The FBReader is also useful to read free book app ebooks which are known as favorite book readers. The eBook format supported by this application is epub, plucker, mobi etc. FBReader also publishes the version of the application which will support DRMed eBook format. FBReader is a cross-platform application that is available for almost all major operating systems such as Linux, Microsoft Windows, Mac OS X and smartphone operating system, such as Android, Java-based mobile, BlackBerry 10 etc. FBReader is written in C ++, with Java programming language and the first year 2013 the license has been released under GPL and supports multiple languages.

How to install FBReader e-Book Reader in Ubuntu 18.04

How to install FBReader e-Book Reader in Ubuntu 18.04

Follow the below steps to install FBReader e-Book Reader in Ubuntu 18.04:

Before starting the installation of FBReader e-Book Reader, update the package and repository of Ubuntu 18.04 using the command given below.

itsmarttricks@mangesh:~$ sudo apt-get update
[sudo] password for itsmarttricks: 
Ign:1 cdrom://Ubuntu 18.04.1 LTS _Bionic Beaver_ - Release amd64 (20180725) bionic InRelease
Err:2 cdrom://Ubuntu 18.04.1 LTS _Bionic Beaver_ - Release amd64 (20180725) bionic Release
Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease 
Hit:4 http://packages.microsoft.com/repos/vscode stable InRelease 
Hit:5 http://ppa.launchpad.net/alessandro-strada/ppa/ubuntu bionic InRelease

Now we are ready to install FBReader e-Book Reader package. So let’s go ahead and install the same using below command.

itsmarttricks@mangesh:~$ sudo apt-get install fbreader
Reading package lists... Done
Building dependency tree 
Reading state information... Done
The following packages were automatically installed and are no longer required:
atril-common fonts-mathjax libatrildocument3 libatrilview3
libcaja-extension1 libjs-mathjax linux-image-unsigned-4.15.0-34-generic
linux-image-unsigned-4.15.0-45-generic linux-modules-4.15.0-34-generic
mate-desktop-common
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
libmng2 libmysqlclient20 libqt4-dbus libqt4-declarative libqt4-network
libqt4-script libqt4-sql libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns
libqtcore4 libqtdbus4 libqtgui4 libunibreak1 libzlcore-data libzlcore0.13
libzltext-data libzltext0.13 libzlui-qt4 mysql-common qdbus qt-at-spi
qtchooser qtcore4-l10n
Suggested packages:
libqt4-declarative-folderlistmodel libqt4-declarative-gestures
libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer
libqt4-dev libicu55 qt4-qtconfig
The following NEW packages will be installed:
fbreader libmng2 libmysqlclient20 libqt4-dbus libqt4-declarative
libqt4-network libqt4-script libqt4-sql libqt4-sql-mysql libqt4-xml
libqt4-xmlpatterns libqtcore4 libqtdbus4 libqtgui4 libunibreak1
libzlcore-data libzlcore0.13 libzltext-data libzltext0.13 libzlui-qt4
mysql-common qdbus qt-at-spi qtchooser qtcore4-l10n
0 upgraded, 25 newly installed, 0 to remove and 62 not upgraded.
Need to get 13.3 MB of archives.
After this operation, 51.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://in.archive.ubuntu.com/ubuntu bionic/universe amd64 libmng2 amd64 2.0.2-0ubuntu3 [169 kB]
Get:2 http://in.archive.ubuntu.com/ubuntu bionic/universe amd64 libzlcore-data all 0.12.10dfsg2-2 [344 kB]

As you can see above we have successfully installed the FBReader e-Book Reader package. Now to confirm the same use the below command.

itsmarttricks@mangesh:~$ sudo dpkg -l fbreader
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii fbreader 0.12.10dfsg2 amd64 e-book reader

Also Read- How to install Evince Document Viewer in Ubuntu 18.04

Now to open the FBReader e-Book Reader application just type the command fbreader on shell prompt. Refer to the command below.

itsmarttricks@mangesh:~$ fbreader
How to install FBReader e-Book Reader in Ubuntu 18.04

FBReader e-Book Reader

You can also open the FBReader e-Book Reader application graphically using Search your Ubuntu Applications box. Refer to the snapshot below.

How to install FBReader e-Book Reader in Ubuntu 18.04

FBReader e-Book Reader

Also Read- How to install Atril Document Viewer in Ubuntu 18.04

How To Uninstall FBReader e-Book Reader in Ubuntu 18.04?

For any reasons, if you don’t like FBReader e-Book Reader and want to uninstall the application from your system using the following command.

itsmarttricks@mangesh:~$ sudo dpkg -r fbreader
(Reading database ... 200211 files and directories currently installed.)
Removing fbreader (0.12.10dfsg2-2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...

That’s all, In this article, we have explained How to install FBReader e-Book Reader in Ubuntu 18.04. I hope you enjoy this article. If you like this article, then just share it. If you have any questions about this article, please comment.

Mangesh Dhulap

This is Mangesh Dhulap the Founder and Editor of IT SMART TRICKS have 6+ years of Industrial Experience. We expect from our visitors to like, share, and comment on our posts.

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.